Swedbank - Delay in transactions and balances

Incident Report for Aritma AS

Resolved

We have recently experienced an issue affecting file intake, which has now been resolved. During the affected period, some transactions were not processed as expected. Our team is actively working through the backlog and expects everything to be fully caught up during Monday
Posted May 29, 2026 - 16:26 CEST

Update

We are continuing to investigate this issue
Posted May 29, 2026 - 11:51 CEST

Investigating

We are currently investigating an issue causing delays in transactions and balances for Swedbank customers
Posted May 29, 2026 - 09:52 CEST
This incident affected: Bank Connections (Swedbank).