Most services have been restored, we are still monitoring the situation.
Posted Sep 12, 2025 - 11:25 CEST
Monitoring
All our Plug&Play products are now operational and working as expected. However, we are still working on the bank connection part, which will cause users to experience issues with bank-related functionality. We are actively working on resolving this and will provide an update continuously.
Posted Sep 12, 2025 - 11:13 CEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 12, 2025 - 11:02 CEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 12, 2025 - 10:38 CEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 12, 2025 - 08:57 CEST
Identified
The issue has been identified and is related to problems with one of our system providers.
Posted Sep 12, 2025 - 08:35 CEST
Investigating
We are currently experiencing issues with some internal services, which are affecting all of our products and APIs. Our team is actively working to resolve the problem.
Posted Sep 12, 2025 - 00:15 CEST
This incident affected: API (Banking, Accounting, Commerce, PSD2 API).